]> git.pld-linux.org Git - packages/perl-libwww.git/blame - perl-libwww.spec
- .pod cleanup
[packages/perl-libwww.git] / perl-libwww.spec
CommitLineData
377e53b5 1#
5a01b76e 2# Conditional build:
3e6aff4b 3%bcond_with tests # perform "make test" (uses network)
377e53b5 4#
2128e5d3 5%include /usr/lib/rpm/macros.perl
e6e936d4 6%define pdir WWW
7%define pnam libwww-perl
5a01b76e 8Summary: libwww-perl - a simple and consistent API to the World-Wide Web
5f0e6283 9Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9c46f5b6 10Name: perl-libwww
e23e58c8 11Version: 6.35
64e31c17 12Release: 1
377e53b5 13# same as perl
14License: GPL v1+ or Artistic
2128e5d3 15Group: Development/Languages/Perl
00779220 16Source0: http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/%{pnam}-%{version}.tar.gz
e23e58c8 17# Source0-md5: 19cd0f55f61359c973caa9301ec405bd
f5ef0868 18URL: http://search.cpan.org/dist/libwww-perl/
3e6aff4b
JB
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
f387c65e 21BuildRequires: rpmbuild(macros) >= 1.663
3e6aff4b 22%if %{with tests}
44760cc9 23BuildRequires: perl(Net::FTP) >= 2.58
e3a00125 24BuildRequires: perl-Digest-MD5
3e6aff4b
JB
25BuildRequires: perl-Encode >= 2.12
26BuildRequires: perl-Encode-Locale
27BuildRequires: perl-File-Listing >= 6
372188ef 28BuildRequires: perl-HTML-Parser >= 3.33
3e6aff4b
JB
29BuildRequires: perl-HTTP-Cookies >= 6
30BuildRequires: perl-HTTP-Daemon >= 6
31BuildRequires: perl-HTTP-Date >= 6
32BuildRequires: perl-HTTP-Message >= 6
33BuildRequires: perl-HTTP-Negotiate >= 6
34BuildRequires: perl-LWP-MediaTypes >= 6
372188ef 35BuildRequires: perl-MIME-Base64 >= 2.1
f387c65e 36BuildRequires: perl-Net-HTTP >= 6.04
372188ef 37BuildRequires: perl-URI >= 1.10
3e6aff4b 38BuildRequires: perl-WWW-RobotRules >= 6
2128e5d3 39BuildRequires: perl-libnet
3e6aff4b
JB
40%endif
41Requires: perl-File-Listing >= 6
42Requires: perl-HTTP-Cookies >= 6
43Requires: perl-HTTP-Daemon >= 6
44Requires: perl-HTTP-Date >= 6
45Requires: perl-HTTP-Message >= 6
46Requires: perl-HTTP-Negotiate >= 6
47Requires: perl-LWP-MediaTypes >= 6
48Requires: perl-MIME-Base64 >= 2.1
f387c65e 49Requires: perl-Net-HTTP >= 6.04
3e6aff4b
JB
50Requires: perl-URI >= 1.10
51Requires: perl-WWW-RobotRules >= 6
d2d1125d 52Obsoletes: perl-libwww-perl
fdae6112 53BuildArch: noarch
af046231 54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
03d3a68a 55
11092ec3 56# modules not always required
f387c65e 57%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
11092ec3 58
03d3a68a 59%description
5a01b76e 60The libwww-perl collection is a set of Perl modules which provides a
d2d1125d
ER
61simple and consistent application programming interface to the
62World-Wide Web. The main focus of the library is to provide classes
63and functions that allow you to write WWW clients. The library also
64contain modules that are of more general use and even classes that
65help you implement simple HTTP servers.
03d3a68a 66
4dcbc77b
JR
67%description -l pl.UTF-8
68libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
d2d1125d
ER
69do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
70udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
71Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
72nawet klasy, pozwalające na implementację prostego serwera HTTP.
1574779f 73
03d3a68a 74%prep
9c46f5b6 75%setup -q -n libwww-perl-%{version}
03d3a68a
AM
76
77%build
667f460d 78yes | %{__perl} Makefile.PL \
44760cc9 79 INSTALLDIRS=vendor
89fabf57 80%{__make}
03d3a68a 81
1724ad1d 82%{?with_tests:%{__make} test}
5a01b76e 83
03d3a68a 84%install
9c46f5b6 85rm -rf $RPM_BUILD_ROOT
9c46f5b6 86
3e6aff4b 87%{__make} pure_install \
60f953d0 88 DESTDIR=$RPM_BUILD_ROOT
9c46f5b6 89
328e8fcd 90for file in GET HEAD POST; do
91 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
328e8fcd 92 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
93done
28788727 94%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
328e8fcd 95
03d3a68a 96%clean
85a3c1ae 97rm -rf $RPM_BUILD_ROOT
03d3a68a
AM
98
99%files
e3a00125 100%defattr(644,root,root,755)
3e6aff4b
JB
101%doc Changes README*
102%attr(755,root,root) %{_bindir}/GET
103%attr(755,root,root) %{_bindir}/HEAD
104%attr(755,root,root) %{_bindir}/POST
105%attr(755,root,root) %{_bindir}/lwp-*
106%{perl_vendorlib}/LWP.pm
107%{perl_vendorlib}/LWP/Authen
108%{perl_vendorlib}/LWP/ConnCache.pm
109%{perl_vendorlib}/LWP/Debug.pm
e23e58c8
MK
110%dir %{perl_vendorlib}/LWP/Debug
111%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
3e6aff4b
JB
112%{perl_vendorlib}/LWP/DebugFile.pm
113%{perl_vendorlib}/LWP/MemberMixin.pm
114%{perl_vendorlib}/LWP/Protocol.pm
115%{perl_vendorlib}/LWP/Protocol
116%{perl_vendorlib}/LWP/RobotUA.pm
117%{perl_vendorlib}/LWP/Simple.pm
118%{perl_vendorlib}/LWP/UserAgent.pm
119%{_mandir}/man1/GET.1p*
120%{_mandir}/man1/HEAD.1p*
121%{_mandir}/man1/POST.1p*
122%{_mandir}/man1/lwp-*.1p*
123%{_mandir}/man3/LWP*.3pm*
e23e58c8
MK
124%{_mandir}/man3/libwww::lwpcook.3pm*
125%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.076649 seconds and 4 git commands to generate.