]> git.pld-linux.org Git - packages/perl-libwww.git/blame - perl-libwww.spec
- updated to 6.04
[packages/perl-libwww.git] / perl-libwww.spec
CommitLineData
377e53b5 1#
5a01b76e 2# Conditional build:
3e6aff4b 3%bcond_with tests # perform "make test" (uses network)
377e53b5 4#
2128e5d3 5%include /usr/lib/rpm/macros.perl
e6e936d4 6%define pdir WWW
7%define pnam libwww-perl
5a01b76e 8Summary: libwww-perl - a simple and consistent API to the World-Wide Web
5f0e6283 9Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9c46f5b6 10Name: perl-libwww
e4491395 11Version: 6.04
64e31c17 12Release: 1
377e53b5 13# same as perl
14License: GPL v1+ or Artistic
2128e5d3 15Group: Development/Languages/Perl
7780020c 16Source0: http://www.cpan.org/modules/by-module/WWW/GAAS/%{pnam}-%{version}.tar.gz
e4491395 17# Source0-md5: 24acf2fe33b2295f048f8859e9665ee3
f5ef0868 18URL: http://search.cpan.org/dist/libwww-perl/
3e6aff4b
JB
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
44760cc9 22BuildRequires: perl(Net::FTP) >= 2.58
e3a00125 23BuildRequires: perl-Digest-MD5
3e6aff4b
JB
24BuildRequires: perl-Encode >= 2.12
25BuildRequires: perl-Encode-Locale
26BuildRequires: perl-File-Listing >= 6
372188ef 27BuildRequires: perl-HTML-Parser >= 3.33
3e6aff4b
JB
28BuildRequires: perl-HTTP-Cookies >= 6
29BuildRequires: perl-HTTP-Daemon >= 6
30BuildRequires: perl-HTTP-Date >= 6
31BuildRequires: perl-HTTP-Message >= 6
32BuildRequires: perl-HTTP-Negotiate >= 6
33BuildRequires: perl-LWP-MediaTypes >= 6
372188ef 34BuildRequires: perl-MIME-Base64 >= 2.1
3e6aff4b 35BuildRequires: perl-Net-HTTP >= 6
372188ef 36BuildRequires: perl-URI >= 1.10
3e6aff4b 37BuildRequires: perl-WWW-RobotRules >= 6
2128e5d3 38BuildRequires: perl-libnet
3e6aff4b
JB
39%endif
40Requires: perl-File-Listing >= 6
41Requires: perl-HTTP-Cookies >= 6
42Requires: perl-HTTP-Daemon >= 6
43Requires: perl-HTTP-Date >= 6
44Requires: perl-HTTP-Message >= 6
45Requires: perl-HTTP-Negotiate >= 6
46Requires: perl-LWP-MediaTypes >= 6
47Requires: perl-MIME-Base64 >= 2.1
48Requires: perl-Net-HTTP >= 6
49Requires: perl-URI >= 1.10
50Requires: perl-WWW-RobotRules >= 6
d2d1125d 51Obsoletes: perl-libwww-perl
fdae6112 52BuildArch: noarch
af046231 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
03d3a68a 54
11092ec3 55# modules not always required
3e6aff4b 56%define _noautoreq 'perl(HTTP::GHTTP)' 'perl(Authen::NTLM)'
11092ec3 57
03d3a68a 58%description
5a01b76e 59The libwww-perl collection is a set of Perl modules which provides a
d2d1125d
ER
60simple and consistent application programming interface to the
61World-Wide Web. The main focus of the library is to provide classes
62and functions that allow you to write WWW clients. The library also
63contain modules that are of more general use and even classes that
64help you implement simple HTTP servers.
03d3a68a 65
4dcbc77b
JR
66%description -l pl.UTF-8
67libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
d2d1125d
ER
68do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
69udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
70Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
71nawet klasy, pozwalające na implementację prostego serwera HTTP.
1574779f 72
03d3a68a 73%prep
9c46f5b6 74%setup -q -n libwww-perl-%{version}
03d3a68a
AM
75
76%build
667f460d 77yes | %{__perl} Makefile.PL \
44760cc9 78 INSTALLDIRS=vendor
89fabf57 79%{__make}
03d3a68a 80
1724ad1d 81%{?with_tests:%{__make} test}
5a01b76e 82
03d3a68a 83%install
9c46f5b6 84rm -rf $RPM_BUILD_ROOT
9c46f5b6 85
3e6aff4b 86%{__make} pure_install \
60f953d0 87 DESTDIR=$RPM_BUILD_ROOT
9c46f5b6 88
328e8fcd 89for file in GET HEAD POST; do
90 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
91 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
92 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
93done
94
3e6aff4b
JB
95%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod
96
03d3a68a 97%clean
85a3c1ae 98rm -rf $RPM_BUILD_ROOT
03d3a68a
AM
99
100%files
e3a00125 101%defattr(644,root,root,755)
3e6aff4b
JB
102%doc Changes README*
103%attr(755,root,root) %{_bindir}/GET
104%attr(755,root,root) %{_bindir}/HEAD
105%attr(755,root,root) %{_bindir}/POST
106%attr(755,root,root) %{_bindir}/lwp-*
107%{perl_vendorlib}/LWP.pm
108%{perl_vendorlib}/LWP/Authen
109%{perl_vendorlib}/LWP/ConnCache.pm
110%{perl_vendorlib}/LWP/Debug.pm
111%{perl_vendorlib}/LWP/DebugFile.pm
112%{perl_vendorlib}/LWP/MemberMixin.pm
113%{perl_vendorlib}/LWP/Protocol.pm
114%{perl_vendorlib}/LWP/Protocol
115%{perl_vendorlib}/LWP/RobotUA.pm
116%{perl_vendorlib}/LWP/Simple.pm
117%{perl_vendorlib}/LWP/UserAgent.pm
118%{_mandir}/man1/GET.1p*
119%{_mandir}/man1/HEAD.1p*
120%{_mandir}/man1/POST.1p*
121%{_mandir}/man1/lwp-*.1p*
122%{_mandir}/man3/LWP*.3pm*
123%{_mandir}/man3/lwpcook.3pm*
124%{_mandir}/man3/lwptut.3pm*
This page took 0.052995 seconds and 4 git commands to generate.