]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/blob - perl-XML-SAX-Expat.spec
- fix running post(un) scripts
[packages/perl-XML-SAX-Expat.git] / perl-XML-SAX-Expat.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    SAX-Expat
8 Summary:        XML::SAX::Expat - SAX2 driver for Expat (XML::Parser)
9 Summary(pl.UTF-8):      XML::SAX::Expat - sterownik SAX2 dla modułu Expat (XML::Parser)
10 Name:           perl-XML-SAX-Expat
11 Version:        0.51
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  74c540095d84e3f054d1f8703a73ef76
18 URL:            http://search.cpan.org/dist/XML-SAX-Expat/
19 BuildRequires:  perl(XML::SAX::Base) >= 1.00
20 BuildRequires:  perl-XML-NamespaceSupport >= 0.03
21 BuildRequires:  perl-XML-Parser >= 2.27
22 BuildRequires:  perl-XML-SAX >= 0.03
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  sed >= 4.0
26 Requires:       perl-XML-SAX >= 0.03
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is an implementation of a SAX2 driver sitting on top of Expat
32 (XML::Parser).
33
34 %description -l pl.UTF-8
35 To jest implementacja sterownika SAX2 w oparciu o moduł Expat
36 (XML::Parser).
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 # we want to add_parser in post, not on make install
42 %{__sed} -i -e '/^sub MY::install/,/^}/ s/^/#/' Makefile.PL
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 umask 022
62 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
63
64 %postun
65 if [ "$1" = "0" ] && [ -x %{__perl} ]; then
66         umask 022
67         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes
73 %{perl_vendorlib}/XML/SAX/Expat.pm
74 %{_mandir}/man3/XML::SAX::Expat.3pm*
This page took 0.092949 seconds and 4 git commands to generate.