]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/blob - perl-XML-SAX-Expat.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-SAX-Expat.git] / perl-XML-SAX-Expat.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    SAX-Expat
7 Summary:        XML::SAX::Expat - SAX2 driver for Expat (XML::Parser)
8 Summary(pl.UTF-8):      XML::SAX::Expat - sterownik SAX2 dla modułu Expat (XML::Parser)
9 Name:           perl-XML-SAX-Expat
10 Version:        0.51
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  74c540095d84e3f054d1f8703a73ef76
17 URL:            http://search.cpan.org/dist/XML-SAX-Expat/
18 BuildRequires:  perl(XML::SAX::Base) >= 1.00
19 BuildRequires:  perl-XML-NamespaceSupport >= 0.03
20 BuildRequires:  perl-XML-Parser >= 2.27
21 BuildRequires:  perl-XML-SAX >= 0.03
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  sed >= 4.0
25 Requires:       perl-XML-SAX >= 0.03
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is an implementation of a SAX2 driver sitting on top of Expat
31 (XML::Parser).
32
33 %description -l pl.UTF-8
34 To jest implementacja sterownika SAX2 w oparciu o moduł Expat
35 (XML::Parser).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 # we want to add_parser in post, not on make install
41 %{__sed} -i -e '/^sub MY::install/,/^}/ s/^/#/' Makefile.PL
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 umask 022
61 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
62
63 %postun
64 if [ "$1" = "0" ] && [ -x %{__perl} ]; then
65         umask 022
66         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %{perl_vendorlib}/XML/SAX/Expat.pm
73 %{_mandir}/man3/XML::SAX::Expat.3pm*
This page took 0.091965 seconds and 4 git commands to generate.