]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/blob - perl-XML-SAX-Expat.spec
- updated to 0.40
[packages/perl-XML-SAX-Expat.git] / perl-XML-SAX-Expat.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    SAX-Expat
8 Summary:        XML::SAX::Expat - SAX2 driver for Expat (XML::Parser)
9 Summary(pl.UTF-8):      XML::SAX::Expat - sterownik SAX2 dla modułu Expat (XML::Parser)
10 Name:           perl-XML-SAX-Expat
11 Version:        0.40
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ca58d1e26c437b31c52456b4b4ae5c4a
18 URL:            http://search.cpan.org/dist/XML-SAX-Expat/
19 BuildRequires:  perl-XML-NamespaceSupport >= 0.03
20 BuildRequires:  perl-XML-Parser >= 2.27
21 BuildRequires:  perl-XML-SAX >= 0.03
22 BuildRequires:  perl(XML::SAX::Base) >= 1.00
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is an implementation of a SAX2 driver sitting on top of Expat
30 (XML::Parser).
31
32 %description -l pl.UTF-8
33 To jest implementacja sterownika SAX2 w oparciu o moduł Expat
34 (XML::Parser).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 # we want to add_parser in post, not on make install
40 head -n 23 Makefile.PL > Makefile.PL.tmp
41 mv -f Makefile.PL.tmp Makefile.PL
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 umask 022
61 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
62
63 %postun
64 if [ "$1" = "0" ]; then
65         umask 022
66         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %{perl_vendorlib}/XML/SAX/Expat.pm
73 %{_mandir}/man3/*
This page took 0.062463 seconds and 3 git commands to generate.