]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/blob - perl-XML-SAX-Expat.spec
- converted to UTF-8
[packages/perl-XML-SAX-Expat.git] / perl-XML-SAX-Expat.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    SAX-Expat
8 Summary:        XML::SAX::Expat - SAX2 driver for Expat (XML::Parser)
9 Summary(pl.UTF-8):   XML::SAX::Expat - sterownik SAX2 dla modułu Expat (XML::Parser)
10 Name:           perl-XML-SAX-Expat
11 Version:        0.37
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c48024d363a1ff9abaf8f9af592d38cd
18 BuildRequires:  perl-XML-NamespaceSupport >= 0.03
19 BuildRequires:  perl-XML-Parser >= 2.27
20 BuildRequires:  perl-XML-SAX >= 0.03
21 BuildRequires:  perl(XML::SAX::Base) >= 1.00
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is an implementation of a SAX2 driver sitting on top of Expat
29 (XML::Parser).
30
31 %description -l pl.UTF-8
32 To jest implementacja sterownika SAX2 w oparciu o moduł Expat
33 (XML::Parser).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 # we want to add_parser in post, not on make install
39 head -n 16 Makefile.PL > Makefile.PL.tmp
40 mv -f Makefile.PL.tmp Makefile.PL
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 umask 022
60 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
61
62 %postun
63 if [ "$1" = "0" ]; then
64         umask 022
65         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/XML/SAX/Expat.pm
72 %{_mandir}/man3/*
This page took 0.06807 seconds and 3 git commands to generate.