]> git.pld-linux.org Git - packages/perl-XML-Filter-BufferText.git/blob - perl-XML-Filter-BufferText.spec
- new bconds
[packages/perl-XML-Filter-BufferText.git] / perl-XML-Filter-BufferText.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    Filter-BufferText
8 Summary:        XML::Filter::BufferText Perl module - to guarantee characters in one event
9 Summary(pl):    Modu³ Perla XML::Filter::BufferText - gwarancja przes³ania znaków w jednym zdarzeniu
10 Name:           perl-XML-Filter-BufferText
11 Version:        1.01
12 Release:        1
13 License:        Artistic or GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2992c0387632583b966ab9c965b25512
17 %if %{with tests}
18 BuildRequires:  perl-Test-Simple >= 0.40
19 BuildRequires:  perl-XML-SAX >= 0.04
20 BuildRequires:  perl(XML::SAX::Base) >= 1.03
21 %endif
22 BuildRequires:  perl-devel >= 5.6
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-XML-SAX >= 0.04
25 Requires:       perl(XML::SAX::Base) >= 1.03
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a very simple filter. One common cause of grief (and
31 programmer error) is that XML parsers aren't required to provide
32 character events in one chunk. They can, but are not forced to, and
33 most don't. This filter does the trivial but oft-repeated task of
34 putting all characters into a single event.
35
36 %description -l pl
37 To jest bardzo prosty filtr. Jednym z czêstych zmartwieñ (i b³êdów
38 programistów) jest to, ¿e analizatory XML-a nie musz± dostarczaæ
39 zdarzeñ znakowych w jednym kawa³ku. Mog±, ale nie s± do tego zmuszone,
40 i przewa¿nie tego nie robi±. Ten filtr wykonuje trywialne, ale czêsto
41 wykonywane zadanie umieszczania wszystkich znaków w jednym zdarzeniu.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/XML/Filter/BufferText.pm
66 %{_mandir}/man3/*
This page took 0.085618 seconds and 3 git commands to generate.