]> git.pld-linux.org Git - packages/perl-XML-Filter-BufferText.git/blob - perl-XML-Filter-BufferText.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-Filter-BufferText.git] / perl-XML-Filter-BufferText.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    Filter-BufferText
7 Summary:        XML::Filter::BufferText Perl module - to guarantee characters in one event
8 Summary(pl.UTF-8):      Moduł Perla XML::Filter::BufferText - gwarancja przesłania znaków w jednym zdarzeniu
9 Name:           perl-XML-Filter-BufferText
10 Version:        1.01
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2992c0387632583b966ab9c965b25512
17 URL:            http://search.cpan.org/dist/XML-Filter-BufferText/
18 %if %{with tests}
19 BuildRequires:  perl-Test-Simple >= 0.40
20 BuildRequires:  perl-XML-SAX >= 0.04
21 BuildRequires:  perl(XML::SAX::Base) >= 1.03
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       perl-XML-SAX >= 0.04
26 Requires:       perl(XML::SAX::Base) >= 1.03
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is a very simple filter. One common cause of grief (and
32 programmer error) is that XML parsers aren't required to provide
33 character events in one chunk. They can, but are not forced to, and
34 most don't. This filter does the trivial but oft-repeated task of
35 putting all characters into a single event.
36
37 %description -l pl.UTF-8
38 To jest bardzo prosty filtr. Jednym z częstych zmartwień (i błędów
39 programistów) jest to, że analizatory XML-a nie muszą dostarczać
40 zdarzeń znakowych w jednym kawałku. Mogą, ale nie są do tego zmuszone,
41 i przeważnie tego nie robią. Ten filtr wykonuje trywialne, ale często
42 wykonywane zadanie umieszczania wszystkich znaków w jednym zdarzeniu.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/XML/Filter/BufferText.pm
67 %{_mandir}/man3/XML::Filter::BufferText.3pm*
This page took 0.06688 seconds and 4 git commands to generate.