]> git.pld-linux.org Git - packages/perl-XML-Atom.git/blob - perl-XML-Atom.spec
requires XML::LibXML or XML::XPath
[packages/perl-XML-Atom.git] / perl-XML-Atom.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define         pdir    XML
7 %define         pnam    Atom
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        XML::Atom - Atom feed and API implementation
10 Summary(pl.UTF-8):      XML::Atom - implementacja API Atom
11 Name:           perl-XML-Atom
12 Version:        0.41
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  99eeebbf90c95cc1a24426a0b9f2d6a5
19 URL:            http://search.cpan.org/dist/XML-Atom/
20 BuildRequires:  perl-Class-Data-Inheritable
21 BuildRequires:  perl-URI
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with autodeps} && %{with tests}
25 BuildRequires:  perl-DateTime
26 %endif
27 Requires:       perl-XML-XPath
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Atom is a syndication, API, and archiving format for weblogs and other
33 data. XML::Atom implements the feed format as well as a client for the
34 API.
35
36 %description -l pl.UTF-8
37 Atom to API i format archiwów dla blogów i innych danych. XML::Atom
38 implementuje ten format, a także klienta dla tego API.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 # yes i know, its crude, but works, and its simple
43 %{__perl} -pi -e 's/^auto_install/#auto_install/' Makefile.PL;
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/XML/Atom.pm
66 %dir %{perl_vendorlib}/XML/Atom
67 %{perl_vendorlib}/XML/Atom/*.pm
68 %{_mandir}/man3/*
This page took 0.074531 seconds and 3 git commands to generate.