]> git.pld-linux.org Git - packages/perl-XML-Atom.git/blob - perl-XML-Atom.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-Atom.git] / perl-XML-Atom.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define         pdir    XML
7 %define         pnam    Atom
8 Summary:        XML::Atom - Atom feed and API implementation
9 Summary(pl.UTF-8):      XML::Atom - implementacja API Atom
10 Name:           perl-XML-Atom
11 Version:        0.41
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  99eeebbf90c95cc1a24426a0b9f2d6a5
18 URL:            http://search.cpan.org/dist/XML-Atom/
19 BuildRequires:  perl-Class-Data-Inheritable
20 BuildRequires:  perl-URI
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with autodeps} && %{with tests}
24 BuildRequires:  perl-DateTime
25 %endif
26 Requires:       perl-XML-XPath
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Atom is a syndication, API, and archiving format for weblogs and other
32 data. XML::Atom implements the feed format as well as a client for the
33 API.
34
35 %description -l pl.UTF-8
36 Atom to API i format archiwów dla blogów i innych danych. XML::Atom
37 implementuje ten format, a także klienta dla tego API.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 # yes i know, its crude, but works, and its simple
42 %{__perl} -pi -e 's/^auto_install/#auto_install/' Makefile.PL;
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/XML/Atom.pm
65 %dir %{perl_vendorlib}/XML/Atom
66 %{perl_vendorlib}/XML/Atom/*.pm
67 %{_mandir}/man3/*
This page took 0.123455 seconds and 4 git commands to generate.