]> git.pld-linux.org Git - packages/perl-Tree-Trie.git/blob - perl-Tree-Trie.spec
- generic URL
[packages/perl-Tree-Trie.git] / perl-Tree-Trie.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Tree
7 %define         pnam    Trie
8 Summary:        Tree::Trie - an implementation of the Trie data structure in Perl
9 Summary(pl.UTF-8):      Tree::Trie - implementacja perlowa struktury danych Trie
10 Name:           perl-Tree-Trie
11 Version:        1.5
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  132854f975298b71613bbdd78956e32e
18 URL:            http://search.cpan.org/dist/Tree-Trie/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Pod-Coverage
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module implements a trie data structure. The term "trie" comes
29 from the word re*trie*val, but is generally pronounced like "try". A
30 trie is a tree structure (or directed acyclic graph), the nodes of
31 which represent letters in a word. For example, the final lookup for
32 the word 'bob' would look something like
33 $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (the HASH being an end
34 marker). Only nodes which would represent words in the trie exist,
35 making the structure slightly smaller than a hash of the same data
36 set.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją struktury danych Trie. Termin "trie"
40 pochodzi od słowa "re*trie*val" (odtwarzanie, odzyskiwanie), ale
41 jest wymawiany jak angielskie słowo "try". Trie to struktura
42 drzewiasta (lub skierowany graf acykliczny), której węzły reprezentują
43 litery w słowie. Na przykład, końcowe wyszukiwanie słowa "bob" będzie
44 wyglądać podobnie do $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (gdzie
45 HASH jest znacznikiem końca). W strukturze istnieją tylko węzły
46 reprezentujące słowa, co czyni strukturę mniejszą niż hasz z tego
47 samego zbioru danych.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/Tree/Trie.pm
72 %{_mandir}/man3/*
This page took 0.136921 seconds and 4 git commands to generate.