]> git.pld-linux.org Git - packages/perl-Tree-Trie.git/blob - perl-Tree-Trie.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Tree-Trie.git] / perl-Tree-Trie.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Tree
6 %define         pnam    Trie
7 Summary:        Tree::Trie - an implementation of the Trie data structure in Perl
8 Summary(pl.UTF-8):      Tree::Trie - implementacja perlowa struktury danych Trie
9 Name:           perl-Tree-Trie
10 Version:        1.9
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1b823d1896e43279227d65e6ff947d98
17 URL:            http://search.cpan.org/dist/Tree-Trie/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Pod-Coverage
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module implements a trie data structure. The term "trie" comes
28 from the word re*trie*val, but is generally pronounced like "try". A
29 trie is a tree structure (or directed acyclic graph), the nodes of
30 which represent letters in a word. For example, the final lookup for
31 the word 'bob' would look something like
32 $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (the HASH being an end
33 marker). Only nodes which would represent words in the trie exist,
34 making the structure slightly smaller than a hash of the same data
35 set.
36
37 %description -l pl.UTF-8
38 Ten moduł jest implementacją struktury danych Trie. Termin "trie"
39 pochodzi od słowa "re*trie*val" (odtwarzanie, odzyskiwanie), ale
40 jest wymawiany jak angielskie słowo "try". Trie to struktura
41 drzewiasta (lub skierowany graf acykliczny), której węzły reprezentują
42 litery w słowie. Na przykład, końcowe wyszukiwanie słowa "bob" będzie
43 wyglądać podobnie do $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (gdzie
44 HASH jest znacznikiem końca). W strukturze istnieją tylko węzły
45 reprezentujące słowa, co czyni strukturę mniejszą niż hasz z tego
46 samego zbioru danych.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Tree/Trie.pm
71 %{_mandir}/man3/*
This page took 0.048068 seconds and 4 git commands to generate.