]> git.pld-linux.org Git - packages/perl-Tree-Trie.git/blob - perl-Tree-Trie.spec
- pl description, release++
[packages/perl-Tree-Trie.git] / perl-Tree-Trie.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Tree
3 %define pnam    Trie
4 Summary:        Tree::Trie - An implementation of the Trie data structure in Perl
5 Summary(pl):    Tree::Trie - perlowa implementacja struktury danych Trie
6 Name:           perl-Tree-Trie
7 Version:        0.4
8 Release:        3
9 License:        GPL
10 Group:          Development/Languages/Perl
11 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 BuildRequires:  perl >= 5.6
13 BuildRequires:  rpm-perlprov >= 3.0.3-16
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This module implements a trie data structure. The term "trie" comes
19 from the word re*trie*val, but is generally pronounced like "try". A
20 trie is a tree structure (or directed acyclic graph), the nodes of
21 which represent letters in a word. For example, the final lookup for
22 the word 'bob' would look something like
23 $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (the HASH being an end
24 marker). Only nodes which would represent words in the trie exist,
25 making the structure slightly smaller than a hash of the same data
26 set.
27
28 %description -l pl
29 Ten modu³ jest implementacj± struktury danych Trie. Termin "trie"
30 pochodzi od s³owa "re*trie*val" (odtwarzanie, odzyskiwanie), ale
31 jest wymawiany jak angielskie s³owo "try". Trie to struktura
32 drzewiasta (lub skierowany graf acykliczny), której wêz³y reprezentuj±
33 litery w s³owie. Na przyk³ad, koñcowe wyszukiwanie s³owa "bob" bêdzie
34 wygl±daæ podobnie do $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (gdzie
35 HASH jest znacznikiem koñca). W strukturze istniej± tylko wêz³y
36 reprezentuj±ce s³owa, co czyni strukturê mniejsz± ni¿ hasz z tego
37 samego zbioru danych.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 perl Makefile.PL
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_sitelib}/Tree/Trie.pm
58 %{_mandir}/man3/*
This page took 0.089253 seconds and 4 git commands to generate.