]> git.pld-linux.org Git - packages/perl-Tree-Trie.git/blob - perl-Tree-Trie.spec
- cosmetics
[packages/perl-Tree-Trie.git] / perl-Tree-Trie.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Tree
3 %define pnam    Trie
4 Summary:        Tree::Trie - an implementation of the Trie data structure in Perl
5 Summary(pl):    Tree::Trie - implementacja perlowa struktury danych Trie
6 Name:           perl-Tree-Trie
7 Version:        1.0
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 # Source0-md5:  82eb063ab6dd00e78b1aeee52ea553ea
13 BuildRequires:  perl-devel >= 5.6
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This module implements a trie data structure. The term "trie" comes
20 from the word re*trie*val, but is generally pronounced like "try". A
21 trie is a tree structure (or directed acyclic graph), the nodes of
22 which represent letters in a word. For example, the final lookup for
23 the word 'bob' would look something like
24 $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (the HASH being an end
25 marker). Only nodes which would represent words in the trie exist,
26 making the structure slightly smaller than a hash of the same data
27 set.
28
29 %description -l pl
30 Ten modu³ jest implementacj± struktury danych Trie. Termin "trie"
31 pochodzi od s³owa "re*trie*val" (odtwarzanie, odzyskiwanie), ale
32 jest wymawiany jak angielskie s³owo "try". Trie to struktura
33 drzewiasta (lub skierowany graf acykliczny), której wêz³y reprezentuj±
34 litery w s³owie. Na przyk³ad, koñcowe wyszukiwanie s³owa "bob" bêdzie
35 wygl±daæ podobnie do $ref->{'b'}{'o'}{'b'}{HASH(0x80c6bbc)} (gdzie
36 HASH jest znacznikiem koñca). W strukturze istniej± tylko wêz³y
37 reprezentuj±ce s³owa, co czyni strukturê mniejsz± ni¿ hasz z tego
38 samego zbioru danych.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Tree/Trie.pm
60 %{_mandir}/man3/*
This page took 0.062082 seconds and 4 git commands to generate.