]> git.pld-linux.org Git - packages/perl-Text-Diff.git/blob - perl-Text-Diff.spec
- updated Algorithm::Diff BR, more verbose files
[packages/perl-Text-Diff.git] / perl-Text-Diff.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Text
7 %define         pnam    Diff
8 Summary:        Text::Diff - perform diffs on files and record sets
9 Summary(pl.UTF-8):      Text::Diff - wyszukiwanie różnic między plikami i zbiorami rekordów
10 Name:           perl-Text-Diff
11 Version:        1.41
12 Release:        1
13 License:        GPL v2+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  30d56e6dd5551ca16b8e16cc7299dc21
17 URL:            http://search.cpan.org/dist/Text-Diff/
18 %if %{with tests}
19 BuildRequires:  perl-Algorithm-Diff >= 1.19
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 diff() provides a basic set of services akin to the GNU diff utility.
28 It is not anywhere near as feature complete as GNU diff, but it is
29 better integrated with Perl and available on all platforms. It is
30 often faster than shelling out to a system's diff executable for small
31 files, and generally slower on larger files.
32
33 %description -l pl.UTF-8
34 Funkcja diff() udostępnia podstawowy zbiór usług podobnych do
35 narzędzia GNU diff. Daleko jej do pełnej funkcjonalności GNU diffa,
36 ale jest lepiej zintegrowana z Perlem i dostępna na wszystkich
37 platformach. Jest przeważnie szybsza niż uruchamianie polecenia
38 systemowego w przypadku małych plików, a wolniejsza dla dużych plików.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %{perl_vendorlib}/Text/Diff.pm
62 %{perl_vendorlib}/Text/Diff
63 %{_mandir}/man3/Text::Diff*.3pm*
This page took 0.064982 seconds and 3 git commands to generate.