]> git.pld-linux.org Git - packages/perl-Text-Diff.git/blob - perl-Text-Diff.spec
- updated to 1.45
[packages/perl-Text-Diff.git] / perl-Text-Diff.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Text
6 %define         pnam    Diff
7 Summary:        Text::Diff - perform diffs on files and record sets
8 Summary(pl.UTF-8):      Text::Diff - wyszukiwanie różnic między plikami i zbiorami rekordów
9 Name:           perl-Text-Diff
10 Version:        1.45
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  edf57b6189f7651a6be454062a4e6d9c
17 URL:            https://metacpan.org/release/Text-Diff
18 %if %{with tests}
19 BuildRequires:  perl-Algorithm-Diff >= 1.19
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 diff() provides a basic set of services akin to the GNU diff utility.
29 It is not anywhere near as feature complete as GNU diff, but it is
30 better integrated with Perl and available on all platforms. It is
31 often faster than shelling out to a system's diff executable for small
32 files, and generally slower on larger files.
33
34 %description -l pl.UTF-8
35 Funkcja diff() udostępnia podstawowy zbiór usług podobnych do
36 narzędzia GNU diff. Daleko jej do pełnej funkcjonalności GNU diffa,
37 ale jest lepiej zintegrowana z Perlem i dostępna na wszystkich
38 platformach. Jest przeważnie szybsza niż uruchamianie polecenia
39 systemowego w przypadku małych plików, a wolniejsza dla dużych plików.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes
63 %{perl_vendorlib}/Text/Diff.pm
64 %{perl_vendorlib}/Text/Diff
65 %{_mandir}/man3/Text::Diff*.3pm*
This page took 0.113645 seconds and 4 git commands to generate.