]> git.pld-linux.org Git - packages/perl-Test-UseAllModules.git/blob - perl-Test-UseAllModules.spec
- up to 0.13
[packages/perl-Test-UseAllModules.git] / perl-Test-UseAllModules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    UseAllModules
8 Summary:        Test::UseAllModules - do use_ok() for all the MANIFESTed modules
9 Summary(pl.UTF-8):      Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
10 Name:           perl-Test-UseAllModules
11 Version:        0.13
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b591f8f8de76dd36422a60e2d02fcbdd
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Test-UseAllModules/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 I'm sick of writing 00_load.t (or something like that) that'll do
29 use_ok() for every module I write. I'm sicker of updating 00_load.t
30 when I add another file to the distro. This module reads MANIFEST to
31 find modules to be tested and does use_ok() for each of them. Now all
32 you have to do is update MANIFEST. You don't have to modify the test
33 any more (hopefully).
34
35 %description -l pl.UTF-8
36 Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Test/*.pm
61 %{_mandir}/man3/*
This page took 0.241987 seconds and 3 git commands to generate.