]> git.pld-linux.org Git - packages/perl-Test-UseAllModules.git/blob - perl-Test-UseAllModules.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-UseAllModules.git] / perl-Test-UseAllModules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Test
6 %define pnam    UseAllModules
7 Summary:        Test::UseAllModules - do use_ok() for all the MANIFESTed modules
8 Summary(pl.UTF-8):      Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
9 Name:           perl-Test-UseAllModules
10 Version:        0.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b591f8f8de76dd36422a60e2d02fcbdd
17 URL:            http://search.cpan.org/dist/Test-UseAllModules/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 I'm sick of writing 00_load.t (or something like that) that'll do
25 use_ok() for every module I write. I'm sicker of updating 00_load.t
26 when I add another file to the distro. This module reads MANIFEST to
27 find modules to be tested and does use_ok() for each of them. Now all
28 you have to do is update MANIFEST. You don't have to modify the test
29 any more (hopefully).
30
31 %description -l pl.UTF-8
32 Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Test/*.pm
57 %{_mandir}/man3/*
This page took 0.076469 seconds and 4 git commands to generate.