]> git.pld-linux.org Git - packages/perl-Test-Differences.git/blob - perl-Test-Differences.spec
- new bconds
[packages/perl-Test-Differences.git] / perl-Test-Differences.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Differences
8 Summary:        Test::Differences - test strings and data structures and show differences if not ok
9 Summary(pl):    Test::Differences - kontrola ³añcuchów i struktur danych z pokazywaniem ró¿nic
10 Name:           perl-Test-Differences
11 Version:        0.47
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e4fa76bb11b0d1db2d4213390413f5af
17 BuildRequires:  perl-devel >= 5.6
18 %if %{with tests}
19 BuildRequires:  perl-Text-Diff
20 %endif
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 When the code you're testing returns multiple lines or records and
27 they're just plain wrong, sometimes an equivalent to the Unix diff
28 utility is just what's needed.
29
30 %description -l pl
31 Je¶li testowany kod zwraca wiele linii lub rekordów, które s±
32 niepoprawne, czasem przydatny jest odpowiednik uniksowego narzêdzia
33 diff.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/%{pdir}/*.pm
57 %{_mandir}/man3/*
This page took 0.127489 seconds and 3 git commands to generate.