]> git.pld-linux.org Git - packages/perl-Test-Differences.git/blob - perl-Test-Differences.spec
- updated to 0.67
[packages/perl-Test-Differences.git] / perl-Test-Differences.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    Differences
7 Summary:        Test::Differences - test strings and data structures and show differences if not ok
8 Summary(pl.UTF-8):      Test::Differences - kontrola łańcuchów i struktur danych z pokazywaniem różnic
9 Name:           perl-Test-Differences
10 Version:        0.67
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4a18533f77d43d9feaa1b6ab3dc72735
18 URL:            https://metacpan.org/release/Test-Differences
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(Data::Dumper) >= 2.126
24 BuildRequires:  perl-Capture-Tiny >= 0.24
25 BuildRequires:  perl-Test-Simple >= 0.88
26 BuildRequires:  perl-Text-Diff >= 1.43
27 %endif
28 Requires:       perl-Text-Diff >= 1.43
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 When the code you're testing returns multiple lines or records and
34 they're just plain wrong, sometimes an equivalent to the Unix diff
35 utility is just what's needed.
36
37 %description -l pl.UTF-8
38 Jeśli testowany kod zwraca wiele linii lub rekordów, które są
39 niepoprawne, czasem przydatny jest odpowiednik uniksowego narzędzia
40 diff.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %{perl_vendorlib}/Test/Differences.pm
65 %{_mandir}/man3/Test::Differences.3pm*
This page took 0.250926 seconds and 4 git commands to generate.