]> git.pld-linux.org Git - packages/perl-Tee.git/blob - perl-Tee.spec
- new
[packages/perl-Tee.git] / perl-Tee.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Tee
7 Summary:        Tee - Pure Perl emulation of GNU tee
8 #Summary(pl.UTF-8):     
9 Name:           perl-Tee
10 Version:        0.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/D/DA/DAGOLDEN/Tee-0.13.tar.gz
16 # Source0-md5:  8641888d46b1d50125eb518664d822f0
17 URL:            http://search.cpan.org/dist/Tee/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Probe::Perl)
22 BuildRequires:  perl-IPC-Run3 >= 0.033
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Tee distribution provides the ptee program, a pure Perl emulation of
29 the standard GNU tool tee.  It is designed to be a platform-independent
30 replacement for operating systems without a native tee program.  As with
31 tee, it passes input received on STDIN through to STDOUT while also writing a
32 copy of the input to one or more files.  By default, files will be overwritten.
33
34 # %description -l pl.UTF-8
35 # TODO
36
37 %prep
38 %setup -q -n %{pdir}-%{version}
39
40 %build
41 %{__perl} Build.PL \
42         destdir=$RPM_BUILD_ROOT \
43         installdirs=vendor
44 ./Build
45
46 %{?with_tests:./Build test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 ./Build install
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %attr(755,root,root) %{_bindir}/*
60 %{perl_vendorlib}/*.pm
61 %{_mandir}/man?/*
This page took 0.301291 seconds and 4 git commands to generate.