]> git.pld-linux.org Git - packages/perl-Tee.git/blob - perl-Tee.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Tee.git] / perl-Tee.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Tee
6 Summary:        Tee - Pure Perl emulation of GNU tee
7 #Summary(pl.UTF-8):     
8 Name:           perl-Tee
9 Version:        0.14
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/D/DA/DAGOLDEN/Tee-%{version}.tar.gz
15 # Source0-md5:  5c189150962550b0348c31f6f3e6ad62
16 URL:            http://search.cpan.org/dist/Tee/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Probe::Perl)
21 BuildRequires:  perl-IO-CaptureOutput
22 BuildRequires:  perl-IPC-Run3 >= 0.033
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Tee distribution provides the ptee program, a pure Perl emulation
29 of the standard GNU tool tee.  It is designed to be a
30 platform-independent replacement for operating systems without a
31 native tee program. As with tee, it passes input received on STDIN
32 through to STDOUT while also writing a copy of the input to one or
33 more files.  By default, files will be overwritten.
34
35 # %description -l pl.UTF-8
36 # TODO
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         destdir=$RPM_BUILD_ROOT \
44         installdirs=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %attr(755,root,root) %{_bindir}/*
61 %{perl_vendorlib}/*.pm
62 %{perl_vendorlib}/Tee
63 %{_mandir}/man?/*
This page took 0.111524 seconds and 4 git commands to generate.