]> git.pld-linux.org Git - packages/perl-SQL-Statement.git/blob - perl-SQL-Statement.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-SQL-Statement.git] / perl-SQL-Statement.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    SQL
6 %define         pnam    Statement
7 Summary:        SQL::Statement - SQL parsing and processing engine
8 Summary(pl.UTF-8):      SQL::Statement - silnik do przetwarzania i analizy SQL
9 Name:           perl-SQL-Statement
10 Version:        1.412
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/SQL/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa3653325bb627e32021240ff0af3b05
17 URL:            http://search.cpan.org/dist/SQL-Statement/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Clone >= 0.30
21 BuildRequires:  perl-Math-Base-Convert
22 BuildRequires:  perl-Math-Complex >= 1.56
23 BuildRequires:  perl-Math-BigInt >= 1.88
24 BuildRequires:  perl-Params-Util >= 1.00
25 BuildRequires:  perl-Scalar-List-Utils >= 1.0
26 BuildRequires:  perl-Test-Deep
27 BuildRequires:  perl-Test-Simple >= 0.90
28 BuildRequires:  perl-Text-Balanced
29 BuildRequires:  perl-Text-Soundex >= 3.04
30 %endif
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 Conflicts:      perl-DBD-AnyData < 0.09
33 Conflicts:      perl-DBD-CSV < 0.29
34 Conflicts:      perl-DBI < 1.611
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Modules from this package can be used stand-alone to parse SQL
40 statements or used with DBI and DBD::CSV, DBD::AnyData or other
41 drivers to create, modify, and query data in many kinds of formats
42 including XML, CSV, Fixed Length, Excel Spreadsheets and many others.
43
44 %description -l pl.UTF-8
45 Moduły z tego pakietu mogą być używane samodzielnie do analizy
46 poleceń SQL, jak też razem ze sterownikami DBI i DBD::CSV,
47 DBD::AnyData lub innymi, do tworzenia i modyfikacji danych oraz
48 do wykonywania zapytań przy użyciu danych w wielu formatach, włączając
49 XML, CSV, dane o stałym rozmiarze, arkusze Excela i wiele innych.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %{perl_vendorlib}/SQL/Dialects
75 %{perl_vendorlib}/SQL/Statement
76 %{perl_vendorlib}/SQL/Eval.pm
77 %{perl_vendorlib}/SQL/Parser.pm
78 %{perl_vendorlib}/SQL/Statement.pm
79 %{_mandir}/man3/SQL::Dialects::*.3pm*
80 %{_mandir}/man3/SQL::Eval.3pm*
81 %{_mandir}/man3/SQL::Parser.3pm*
82 %{_mandir}/man3/SQL::Statement*.3pm*
This page took 0.076034 seconds and 4 git commands to generate.