]> git.pld-linux.org Git - packages/perl-Pod-Coverage.git/blob - perl-Pod-Coverage.spec
- ver. 0.18
[packages/perl-Pod-Coverage.git] / perl-Pod-Coverage.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Pod
7 %define         pnam    Coverage
8 Summary:        Pod::Coverage - checks if the documentation of a module is comprehensive
9 Summary(pl):    Pod::Coverage - sprawdzanie kompletno¶ci dokumentacji modu³u
10 Name:           perl-Pod-Coverage
11 Version:        0.18
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  12e4f06fa8411a1f5011d3e6ce3628b3
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl-Module-Build >= 0.21-2
20 %if %{with tests}
21 BuildRequires:  perl-Devel-Symdump >= 2.01
22 BuildRequires:  perl-Pod-Parser >= 1.16
23 BuildRequires:  perl-Test-Simple
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides a mechanism for determining if the pod for a
31 given module is comprehensive. It expects to find either a =head(n>1)
32 or an =item block documenting a subroutine.
33
34 %description -l pl
35 Ten modu³ udostêpnia mechamizm do okre¶lania, czy dokumentacja pod dla
36 danego modu³u jest kompletna. Oczekuje bloku =head(n>1) lub =item
37 opisuj±cego funkcjê.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Build.PL \
44         installdirs=vendor \
45         perl="%{__perl}" \
46         destdir=$RPM_BUILD_ROOT
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/*
62 %{perl_vendorlib}/Pod/*.pm
63 %{perl_vendorlib}/Pod/Coverage
64 %{_mandir}/man3/*
This page took 0.081456 seconds and 3 git commands to generate.