]> git.pld-linux.org Git - packages/perl-Pod-Coverage.git/blob - perl-Pod-Coverage.spec
- macros for perl autodeps
[packages/perl-Pod-Coverage.git] / perl-Pod-Coverage.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Pod
6 %define         pnam    Coverage
7 Summary:        Pod::Coverage - checks if the documentation of a module is comprehensive
8 Summary(pl.UTF-8):      Pod::Coverage - sprawdzanie kompletności dokumentacji modułu
9 Name:           perl-Pod-Coverage
10 Version:        0.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Pod/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  12229e553ee7887680ee3db11da5ee52
17 URL:            https://metacpan.org/release/Pod-Coverage
18 BuildRequires:  perl-Module-Build >= 0.21-2
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Devel-Symdump >= 2.01
24 BuildRequires:  perl-Pod-Parser >= 1.13
25 BuildRequires:  perl-Test-Pod >= 1.00
26 BuildRequires:  perl-Test-Simple
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module provides a mechanism for determining if the pod for a
33 given module is comprehensive. It expects to find either a =head(n>1)
34 or an =item block documenting a subroutine.
35
36 %description -l pl.UTF-8
37 Ten moduł udostępnia mechamizm do określania, czy dokumentacja pod dla
38 danego modułu jest kompletna. Oczekuje bloku =head(n>1) lub =item
39 opisującego funkcję.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_bindir}/pod_cover
63 %{perl_vendorlib}/Pod/Coverage.pm
64 %{perl_vendorlib}/Pod/Coverage
65 %{_mandir}/man3/Pod::Coverage*.3pm*
This page took 0.072216 seconds and 4 git commands to generate.