]> git.pld-linux.org Git - packages/perl-PerlIO-via-symlink.git/blob - perl-PerlIO-via-symlink.spec
use generic url
[packages/perl-PerlIO-via-symlink.git] / perl-PerlIO-via-symlink.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    PerlIO
6 %define         pnam    via-symlink
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        PerlIO::via::symlink - PerlIO layers for create symlinks
9 Summary(pl.UTF-8):      PerlIO::via::symlink - warstwy PerlIO do tworzenia symlinków
10 Name:           perl-PerlIO-via-symlink
11 Version:        0.05
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bf33533dba6a48eb459a15df15c8415f
18 URL:            http://search.cpan.org/dist/PerlIO-via-symlink/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The PerlIO layer symlink allows you to create a symbolic link by
26 writing to the file handle.
27
28 You need to write "link $name" to the file handle. If the format does
29 not match, close will fail with EINVAL.
30
31 %description -l pl.UTF-8
32 Warstwa PerlIO symlink umożliwia tworzenie dowiązań symbolicznych
33 poprzez zapis do uchwytu pliku.
34
35 Wystarczy zapisać "link $name" do uchwytu pliku. Jeśli format się nie
36 zgadza, close nie powiedzie się z kodem EINVAL.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES README
60 %{perl_vendorlib}/PerlIO/via/*.pm
61 %{_mandir}/man3/*
This page took 0.110138 seconds and 3 git commands to generate.