]> git.pld-linux.org Git - packages/perl-PerlIO-via-symlink.git/blob - perl-PerlIO-via-symlink.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-PerlIO-via-symlink.git] / perl-PerlIO-via-symlink.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    PerlIO
6 %define         pnam    via-symlink
7 Summary:        PerlIO::via::symlink - PerlIO layers for create symlinks
8 Summary(pl.UTF-8):      PerlIO::via::symlink - warstwy PerlIO do tworzenia symlinków
9 Name:           perl-PerlIO-via-symlink
10 Version:        0.05
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bf33533dba6a48eb459a15df15c8415f
17 URL:            http://search.cpan.org/dist/PerlIO-via-symlink/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The PerlIO layer symlink allows you to create a symbolic link by
25 writing to the file handle.
26
27 You need to write "link $name" to the file handle. If the format does
28 not match, close will fail with EINVAL.
29
30 %description -l pl.UTF-8
31 Warstwa PerlIO symlink umożliwia tworzenie dowiązań symbolicznych
32 poprzez zapis do uchwytu pliku.
33
34 Wystarczy zapisać "link $name" do uchwytu pliku. Jeśli format się nie
35 zgadza, close nie powiedzie się z kodem EINVAL.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc CHANGES README
59 %{perl_vendorlib}/PerlIO/via/*.pm
60 %{_mandir}/man3/*
This page took 0.438787 seconds and 4 git commands to generate.