]> git.pld-linux.org Git - packages/perl-PerlIO-utf8_strict.git/blob - perl-PerlIO-utf8_strict.spec
- fix package name
[packages/perl-PerlIO-utf8_strict.git] / perl-PerlIO-utf8_strict.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    PerlIO
7 %define         pnam    utf8_strict
8 Summary:        PerlIO::utf8_strict - Fast and correct UTF-8 IO
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.005
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6b971926fa3dbd2af494753004a279a0
17 URL:            http://search.cpan.org/dist/PerlIO-utf8_strict/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a fast and correct UTF-8 PerlIO layer.
24 Unlike perl's default :utf8 layer it checks the input for correctness.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Build.PL \
31         destdir=$RPM_BUILD_ROOT \
32         installdirs=vendor
33
34 ./Build \
35         CC="%{__cc}" \
36         OPTIMIZE="%{rpmcflags}"
37
38 %{?with_tests:./Build test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 ./Build install
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes
51 %{perl_vendorarch}/PerlIO/utf8_strict.pm
52 %dir %{perl_vendorarch}/auto/PerlIO/utf8_strict
53 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/utf8_strict/*.so
54 %{_mandir}/man3/*
This page took 0.069506 seconds and 3 git commands to generate.