]> git.pld-linux.org Git - packages/perl-PerlIO-utf8_strict.git/blob - perl-PerlIO-utf8_strict.spec
perl 5.38.0 rebuild
[packages/perl-PerlIO-utf8_strict.git] / perl-PerlIO-utf8_strict.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    PerlIO
6 %define         pnam    utf8_strict
7 Summary:        PerlIO::utf8_strict - fast and correct UTF-8 I/O
8 Summary(pl.UTF-8):      PerlIO::utf8_strict - szybkie i poprawne we/wy UTF-8
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.010
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d90ca967f66e05ad9221c79060868346
17 URL:            https://metacpan.org/dist/PerlIO-utf8_strict
18 %if %{with tests}
19 BuildRequires:  perl-Test-Exception
20 BuildRequires:  perl-Test-Simple >= 0.88
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides a fast and correct UTF-8 PerlIO layer. Unlike
29 Perl's default :utf8 layer it checks the input for correctness.
30
31 %description -l pl.UTF-8
32 Ten moduł zapewnia warstwę PerlIO do szybkiego i poprawnego UTF-8. W
33 przeciwieństwie do domyślnej warstwy :utf8 Perla, sprawdza wejście pod
34 kątem poprawności.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/PerlIO/utf8_strict.pm
59 %dir %{perl_vendorarch}/auto/PerlIO/utf8_strict
60 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/utf8_strict/utf8_strict.so
61 %{_mandir}/man3/PerlIO::utf8_strict.3pm*
This page took 0.077837 seconds and 4 git commands to generate.