]> git.pld-linux.org Git - packages/perl-PerlIO-eol.git/blob - perl-PerlIO-eol.spec
- rebuild with perl 5.30.0
[packages/perl-PerlIO-eol.git] / perl-PerlIO-eol.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    PerlIO
7 %define         pnam    eol
8 Summary:        PerlIO::eol - PerlIO layer for normalizing line endings
9 Summary(pl.UTF-8):      PerlIO::eol - warstwa PerlIO do normalizacji końców wierszy
10 Name:           perl-PerlIO-eol
11 Version:        0.17
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  da9c763968374de47a49942d35689f00
18 URL:            http://search.cpan.org/dist/PerlIO-eol/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The PerlIO::eol Perl module normalizes any of "CR", "LF", "CRLF" and
25 "Native" into the designated line ending. It works for both input and
26 output handles.
27
28 %description -l pl.UTF-8
29 Moduł Perla PerlIO::eol służy do normalizacji dowolnych spośród
30 następujących zakończeń wierszy: "CR", "LF", "CRLF" do zadanej
31 postaci. Działa zarówno dla plików wejściowych, jak i dla wyjściowych.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorarch}/PerlIO/eol.pm
58 %dir %{perl_vendorarch}/auto/PerlIO/eol
59 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/eol/*.so
60 %{_mandir}/man3/*
This page took 0.147634 seconds and 3 git commands to generate.