]> git.pld-linux.org Git - packages/perl-PerlIO-eol.git/blob - perl-PerlIO-eol.spec
perl 5.38.0 rebuild
[packages/perl-PerlIO-eol.git] / perl-PerlIO-eol.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    PerlIO
6 %define         pnam    eol
7 Summary:        PerlIO::eol - PerlIO layer for normalizing line endings
8 Summary(pl.UTF-8):      PerlIO::eol - warstwa PerlIO do normalizacji końców wierszy
9 Name:           perl-PerlIO-eol
10 Version:        0.17
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  da9c763968374de47a49942d35689f00
17 URL:            http://search.cpan.org/dist/PerlIO-eol/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The PerlIO::eol Perl module normalizes any of "CR", "LF", "CRLF" and
24 "Native" into the designated line ending. It works for both input and
25 output handles.
26
27 %description -l pl.UTF-8
28 Moduł Perla PerlIO::eol służy do normalizacji dowolnych spośród
29 następujących zakończeń wierszy: "CR", "LF", "CRLF" do zadanej
30 postaci. Działa zarówno dla plików wejściowych, jak i dla wyjściowych.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorarch}/PerlIO/eol.pm
57 %dir %{perl_vendorarch}/auto/PerlIO/eol
58 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/eol/*.so
59 %{_mandir}/man3/*
This page took 0.091854 seconds and 4 git commands to generate.