]> git.pld-linux.org Git - packages/perl-POE.git/blob - perl-POE.spec
- up to 0.36, rel 0.1 (new fresh from cpan)
[packages/perl-POE.git] / perl-POE.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 Summary:        POE - multitasking and networking framework for Perl
8 Summary(pl):    POE - wielozadaniowe i sieciowe ¶rodowisko dla Perla
9 Name:           perl-POE
10 Version:        0.36
11 Release:        0.3
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  fd8080d1eb9cd687280cf0245daecbf1
18 URL:            http://poe.perl.org/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  perl-Test-Simple >= 0.54
22 %if %{with tests}
23 BuildRequires:  perl(Filter::Util::Call) >= 1.04
24 BuildRequires:  perl-Compress-Zlib
25 BuildRequires:  perl-Curses
26 BuildRequires:  perl-Event
27 BuildRequires:  perl-IO-Tty
28 BuildRequires:  perl-Socket6 >= 0.14
29 BuildRequires:  perl-Storable >= 2.12
30 BuildRequires:  perl-Term-ReadKey >= 2.21
31 BuildRequires:  perl-Time-HiRes >= 1.59
32 BuildRequires:  perl-URI >= 1.30
33 BuildRequires:  perl-libwww
34 %endif
35 Conflicts:      perl-POE-Filter-XML < 0.29
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define _noautoreq      perl(Curses) perl(HTTP::Date) perl(HTTP::Request) perl(HTTP::Response) perl(HTTP::Status) perl(URI) perl(Term::Cap) perl(Term::ReadKey)
40
41 %description
42 POE is an acronym of "Perl Object Environment".  It's a networking
43 and multitasking (some say cooperative threading) framework for Perl.
44 It has been in active development since 1996, with its first open
45 release in 1998.  O'Reilly's Perl Conference (now OSCON) named POE
46 "Best New Module" in 1999.
47
48 POE has been used in mission-critical systems such as internetworked
49 financial markets, file systems, commerce and application servers.
50 It has been used in projects ranging from a few lines of code to tens
51 of thousands.
52
53 POE is compatible with perl versions as old as 5.005_03.
54
55 POE includes an evolving component framework.  Components are high-level,
56 modular, reusable pieces of programs.  Several components have been
57 published on the CPAN, and more are listed on POE's web site.
58
59 POE includes components and libraries for making quick work of network
60 clients, servers, and peers.  A simple stand-alone web application takes
61 about 30 lines of code, most of which is your own custom logic.
62
63 %description -l pl
64 POE to skrót od "Perl Object Environment" (co oznacza "¶rodowisko
65 obiektowe Perla"). Jest to szkielet obs³ugi sieci i wielozadaniowo¶ci
66 (nazywanej przez niektórych "kooperatywnym w±tkowaniem") dla Perla.
67 Jest aktywnie rozwijane od 1996 roku, a pierwsze publiczne wydanie
68 by³o w 1998 roku. Na O'Reilly's Perl Conference (teraz OSCON) w 1999
69 roku POE zosta³o nazwane "Najlepszym nowym modu³em".
70
71 POE jest u¿ywane w systemach mission-critical, takich jak
72 miêdzysieciowe rynki finansowe, systemy plików, serwery aplikacji i
73 handlowe. Jest u¿ywane w projektach o rozmiarach od kilku linii do
74 dziesi±tek tysiêcy.
75
76 POE jest kompatybilne z Perlem od wersji 5.005_03.
77
78 POE zawiera rozwijaj±cy siê szkielet komponentów. Komponenty to
79 wysokopoziomowe, modularne, daj±ce siê wielokrotnie wykorzystywaæ
80 kawa³ki programów. Czê¶æ komponentów zosta³a opublikowana w CPAN,
81 wiêcej mo¿na znale¼æ na stronie WWW POE.
82
83 POE zawiera komponenty i biblioteki do szybkiego tworzenia klientów,
84 serwerów i partnerów sieciowych. Prosta, samodzielna aplikacja WWW
85 zajmuje oko³o 30 linii kodu, z których wiêkszo¶æ to w³a¶ciwa logika.
86
87 %prep
88 %setup -q -n %{pdir}-%{version}
89
90 %build
91 %{__perl} Makefile.PL \
92         INSTALLDIRS=vendor \
93         --default
94 %{__make}
95
96 %{?with_tests:%{__make} test}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/POE/{Component/CD,Session}
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_examplesdir}
105 cp -r samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc CHANGES HISTORY README TODO
113 %{perl_vendorlib}/*.pm
114 %{perl_vendorlib}/POE
115 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
116 %{_mandir}/man3/*
This page took 0.138411 seconds and 3 git commands to generate.