]> git.pld-linux.org Git - packages/perl-POE-Component-IRC.git/blob - perl-POE-Component-IRC.spec
- spaces->tabs
[packages/perl-POE-Component-IRC.git] / perl-POE-Component-IRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    POE
7 %define pnam    Component-IRC
8 Summary:        POE::Component::IRC - a fully event-driven IRC client module
9 Summary(pl):    POE::Component::IRC - modu³ w pe³ni sterowanego zdarzeniami klienta IRC
10 Name:           perl-POE-Component-IRC
11 Version:        2.9
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f35b9b619991ac3eae7dacda06455d31
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE >= 0.06_07
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 POE::Component::IRC is a POE component (who'd have guessed?) which
28 acts as an easily controllable IRC client for your other POE
29 components and sessions. You create an IRC component and tell it what
30 events your session cares about and where to connect to, and it sends
31 back interesting IRC events when they happen. You make the client do
32 things by sending it events. That's all there is to it. Cool, no?
33
34 %description -l pl
35 POE::Component::IRC to komponent POE (któ¿by zgad³?), który
36 funkcjonuje jako ³atwo sterowalny klient IRC dla innych komponentów i
37 sesji POE. Tworzy siê komponent IRC i mówi mu, którymi zdarzeniami
38 zajmuje siê sesja oraz gdzie ma siê po³±czyæ, a on wysy³a z powrotem
39 interesuj±ce zdarzenia IRC, kiedy wyst±pi±. Poprzez wysy³anie zdarzeñ
40 powoduje siê, ¿e klient wykonuje ró¿ne rzeczy. To wszystko, co trzeba
41 zrobiæ. Fajnie, nie?
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 mkdir -p lib/POE/{Component,Filter}
46 mv Filter-CTCP.pm       lib/POE/Filter/CTCP.pm
47 mv Filter-IRC.pm        lib/POE/Filter/IRC.pm
48 mv IRC.pm               lib/POE/Component/IRC.pm
49
50 %build
51 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"POE::Component::IRC")' \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}
64 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/%{pdir}/*/*.pm
73 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
74 %{_mandir}/man3/*
This page took 0.450273 seconds and 4 git commands to generate.