]> git.pld-linux.org Git - packages/perl-POE-Component-IRC.git/blob - perl-POE-Component-IRC.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-IRC.git] / perl-POE-Component-IRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    POE
6 %define         pnam    Component-IRC
7 Summary:        POE::Component::IRC - a fully event-driven IRC client module
8 Summary(pl.UTF-8):      POE::Component::IRC - moduł w pełni sterowanego zdarzeniami klienta IRC
9 Name:           perl-POE-Component-IRC
10 Version:        6.12
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  db28b438ce523308ee12d0a21736502f
17 URL:            http://search.cpan.org/dist/POE-Component-IRC/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(POE::Component::Pluggable) >= 1.24
22 BuildRequires:  perl-POE >= 0.3202
23 BuildRequires:  perl-POE-Component-Client-DNS >= 1:0.99
24 BuildRequires:  perl-POE-Filter-IRCD >= 1.7
25 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 POE::Component::IRC is a POE component (who'd have guessed?) which
32 acts as an easily controllable IRC client for your other POE
33 components and sessions. You create an IRC component and tell it what
34 events your session cares about and where to connect to, and it sends
35 back interesting IRC events when they happen. You make the client do
36 things by sending it events. That's all there is to it. Cool, no?
37
38 %description -l pl.UTF-8
39 POE::Component::IRC to komponent POE (któżby zgadł?), który
40 funkcjonuje jako łatwo sterowalny klient IRC dla innych komponentów i
41 sesji POE. Tworzy się komponent IRC i mówi mu, którymi zdarzeniami
42 zajmuje się sesja oraz gdzie ma się połączyć, a on wysyła z powrotem
43 interesujące zdarzenia IRC, kiedy wystąpią. Poprzez wysyłanie zdarzeń
44 powoduje się, że klient wykonuje różne rzeczy. To wszystko, co trzeba
45 zrobić. Fajnie, nie?
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}
65 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README docs/*
73 %{perl_vendorlib}/POE/Component/IRC.pm
74 %dir %{perl_vendorlib}/POE/Component/IRC
75 %{perl_vendorlib}/POE/Component/IRC/*.pm
76 %dir %{perl_vendorlib}/POE/Component/IRC/Plugin
77 %{perl_vendorlib}/POE/Component/IRC/Plugin/*.pm
78 %dir %{perl_vendorlib}/POE/Component/IRC/Qnet
79 %{perl_vendorlib}/POE/Component/IRC/Qnet/*.pm
80 %{perl_vendorlib}/POE/Filter/IRC.pm
81 %dir %{perl_vendorlib}/POE/Filter/IRC
82 %{perl_vendorlib}/POE/Filter/IRC/Compat.pm
83
84 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
85 %{_mandir}/man3/*
This page took 0.130848 seconds and 4 git commands to generate.