]> git.pld-linux.org Git - packages/perl-POE-Component-IRC.git/blob - perl-POE-Component-IRC.spec
- converted to UTF-8
[packages/perl-POE-Component-IRC.git] / perl-POE-Component-IRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Component-IRC
8 Summary:        POE::Component::IRC - a fully event-driven IRC client module
9 Summary(pl.UTF-8):   POE::Component::IRC - moduł w pełni sterowanego zdarzeniami klienta IRC
10 Name:           perl-POE-Component-IRC
11 Version:        5.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  624c4f967479a9a51599b39da89251ca
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE >= 0.06_07
22 BuildRequires:  perl-POE-Component-Client-DNS >= 1:0.99
23 BuildRequires:  perl-POE-Filter-IRCD
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 POE::Component::IRC is a POE component (who'd have guessed?) which
30 acts as an easily controllable IRC client for your other POE
31 components and sessions. You create an IRC component and tell it what
32 events your session cares about and where to connect to, and it sends
33 back interesting IRC events when they happen. You make the client do
34 things by sending it events. That's all there is to it. Cool, no?
35
36 %description -l pl.UTF-8
37 POE::Component::IRC to komponent POE (któżby zgadł?), który
38 funkcjonuje jako łatwo sterowalny klient IRC dla innych komponentów i
39 sesji POE. Tworzy się komponent IRC i mówi mu, którymi zdarzeniami
40 zajmuje się sesja oraz gdzie ma się połączyć, a on wysyła z powrotem
41 interesujące zdarzenia IRC, kiedy wystąpią. Poprzez wysyłanie zdarzeń
42 powoduje się, że klient wykonuje różne rzeczy. To wszystko, co trzeba
43 zrobić. Fajnie, nie?
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}
63 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README docs/*
71 %{perl_vendorlib}/POE/Component/IRC.pm
72 %dir %{perl_vendorlib}/POE/Component/IRC
73 %{perl_vendorlib}/POE/Component/IRC/*.pm
74 %dir %{perl_vendorlib}/POE/Component/IRC/Plugin
75 %{perl_vendorlib}/POE/Component/IRC/Plugin/*.pm
76 %dir %{perl_vendorlib}/POE/Component/IRC/Qnet
77 %{perl_vendorlib}/POE/Component/IRC/Qnet/*.pm
78 %dir %{perl_vendorlib}/POE/Component/IRC/Test
79 %{perl_vendorlib}/POE/Component/IRC/Test/*.pm
80 %{perl_vendorlib}/POE/Filter/IRC.pm
81 %{perl_vendorlib}/POE/Filter/CTCP.pm
82 %dir %{perl_vendorlib}/POE/Filter/IRC
83 %{perl_vendorlib}/POE/Filter/IRC/Compat.pm
84
85 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
86 %{_mandir}/man3/*
This page took 0.079258 seconds and 3 git commands to generate.