]> git.pld-linux.org Git - packages/perl-Net-MySQL.git/blob - perl-Net-MySQL.spec
- license fixes, cosmetics
[packages/perl-Net-MySQL.git] / perl-Net-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    MySQL
8 Summary:        Net::MySQL - pure Perl MySQL network protocol interface
9 Summary(pl):    Net::MySQL - czysto perlowy interfejs do protoko³u sieciowego MySQL-a
10 Name:           perl-Net-MySQL
11 Version:        0.08
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bb8c17d4d77ab5cba3fd6838b8516444
18 BuildRequires:  perl-devel >= 5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Net::MySQL is a Pure Perl client interface for the MySQL database.
25 This module implements network protocol between server and client of
26 MySQL, thus you don't need external MySQL client library like
27 libmysqlclient for this module to work. It means this module enables
28 you to connect to MySQL server from some operation systems which MySQL
29 is not ported.
30
31 %description -l pl
32 Net::MySQL to czysto perlowy interfejs kliencki do bazy danych MySQL.
33 Ten modu³ jest implementacj± protoko³u sieciowego miêdzy serwerem a
34 klientem MySQL-a, przez co nie wymaga do dzia³ania zewnêtrznej
35 biblioteki klienckiej MySQL-a, takiej jak libmysqlclient. Oznacza to,
36 ¿e modu³ ten umo¿liwia po³±czenie z serwerem MySQL nawet z systemu
37 operacyjnego, na który MySQL nie zosta³ sportowany.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Net/MySQL.pm
63 %{_mandir}/man3/*
This page took 0.059191 seconds and 3 git commands to generate.