]> git.pld-linux.org Git - packages/perl-Net-MySQL.git/blob - perl-Net-MySQL.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-MySQL.git] / perl-Net-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    MySQL
7 Summary:        Net::MySQL - pure Perl MySQL network protocol interface
8 Summary(pl.UTF-8):      Net::MySQL - czysto perlowy interfejs do protokołu sieciowego MySQL-a
9 Name:           perl-Net-MySQL
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  35b62e0f55fa5e2a3d308f602751bb68
17 URL:            http://search.cpan.org/dist/Net-MySQL/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Digest-SHA1
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Net::MySQL is a Pure Perl client interface for the MySQL database.
28 This module implements network protocol between server and client of
29 MySQL, thus you don't need external MySQL client library like
30 libmysqlclient for this module to work. It means this module enables
31 you to connect to MySQL server from some operation systems which MySQL
32 is not ported.
33
34 %description -l pl.UTF-8
35 Net::MySQL to czysto perlowy interfejs kliencki do bazy danych MySQL.
36 Ten moduł jest implementacją protokołu sieciowego między serwerem a
37 klientem MySQL-a, przez co nie wymaga do działania zewnętrznej
38 biblioteki klienckiej MySQL-a, takiej jak libmysqlclient. Oznacza to,
39 że moduł ten umożliwia połączenie z serwerem MySQL nawet z systemu
40 operacyjnego, na który MySQL nie został sportowany.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/Net/MySQL.pm
66 %{_mandir}/man3/*
This page took 0.0985 seconds and 4 git commands to generate.