]> git.pld-linux.org Git - packages/perl-Nagios-Object.git/blob - perl-Nagios-Object.spec
- tabs in preamble
[packages/perl-Nagios-Object.git] / perl-Nagios-Object.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Nagios
7 %define         pnam    Object
8 Summary:        Nagios::Object - Perl objects to represent Nagios objects
9 Summary(pl.UTF-8):      Nagios::Object - obiekty Perla reprezentujące obiekty Nagiosa
10 Name:           perl-Nagios-Object
11 Version:        0.08
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TOBEYA/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  59cf6e6286abcd26674b4da092e4759b
17 URL:            http://search.cpan.org/dist/Nagios-Object/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module contains the code for creating Perl objects to represent
25 any of the Nagios objects. All of the Perl classes are auto-generated
26 at compile-time, so it's pretty trivial to add new attributes or even
27 entire objects.
28
29 %description -l pl.UTF-8
30 Ten moduł zawiera kod do tworzenia obiektów Perla reprezentujących
31 dowolne obiekty Nagiosa. Wszystkie klasy Perla są generowane
32 automatycznie w czasie kompilacji, więc łatwo dodawać nowe atrybuty
33 czy nawet całe obiekty.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         installdirs=vendor \
41         destdir=$RPM_BUILD_ROOT
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a bin/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/.packlist
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog README
61 %{perl_vendorlib}/Nagios
62 %{_mandir}/man3/*
63 %{_examplesdir}/*
This page took 0.108215 seconds and 4 git commands to generate.