]> git.pld-linux.org Git - packages/perl-Nagios-Object.git/blob - perl-Nagios-Object.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Nagios-Object.git] / perl-Nagios-Object.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Nagios
6 %define         pnam    Object
7 Summary:        Nagios::Object - Creates perl objects to represent Nagios objects
8 Summary(pl.UTF-8):      Nagios::Object - obiekty Perla reprezentujące obiekty Nagiosa
9 Name:           perl-Nagios-Object
10 Version:        0.21.20
11 Release:        1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/D/DU/DUNCS/Nagios-Object-%{version}.tar.gz
15 # Source0-md5:  6ece5aff7095bb35192a034c8e788d77
16 URL:            http://search.cpan.org/dist/Nagios-Object/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-List-Compare
22 BuildRequires:  perl-Test-Exception >= 0.01
23 BuildRequires:  perl-Test-NoWarnings >= 0.08
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module contains the code for creating Perl objects to represent
30 any of the Nagios objects. All of the Perl classes are auto-generated
31 at compile-time, so it's pretty trivial to add new attributes or even
32 entire objects.
33
34 %description -l pl.UTF-8
35 Ten moduł zawiera kod do tworzenia obiektów Perla reprezentujących
36 dowolne obiekty Nagiosa. Wszystkie klasy Perla są generowane
37 automatycznie w czasie kompilacji, więc łatwo dodawać nowe atrybuty
38 czy nawet całe obiekty.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Build.PL \
45         installdirs=vendor \
46         destdir=$RPM_BUILD_ROOT
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 mv $RPM_BUILD_ROOT{%{_bindir}/*,%{_examplesdir}/%{name}-%{version}}
57
58 rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
59 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/.packlist
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc ChangeLog README
67 %{perl_vendorlib}/Nagios
68 %{_mandir}/man3/*
69 %{_examplesdir}/%{name}-%{version}
This page took 0.111835 seconds and 4 git commands to generate.