]> git.pld-linux.org Git - packages/perl-Nagios-Object.git/blob - perl-Nagios-Object.spec
up to 0.21.20
[packages/perl-Nagios-Object.git] / perl-Nagios-Object.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Nagios
6 %define         pnam    Object
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Nagios::Object - Creates perl objects to represent Nagios objects
9 Summary(pl.UTF-8):      Nagios::Object - obiekty Perla reprezentujące obiekty Nagiosa
10 Name:           perl-Nagios-Object
11 Version:        0.21.20
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/D/DU/DUNCS/Nagios-Object-%{version}.tar.gz
16 # Source0-md5:  6ece5aff7095bb35192a034c8e788d77
17 URL:            http://search.cpan.org/dist/Nagios-Object/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Test::NoWarnings) >= 0.08
23 BuildRequires:  perl-Test-Exception >= 0.01
24 BuildRequires:  perl-List-Compare
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module contains the code for creating Perl objects to represent
31 any of the Nagios objects. All of the Perl classes are auto-generated
32 at compile-time, so it's pretty trivial to add new attributes or even
33 entire objects.
34
35 %description -l pl.UTF-8
36 Ten moduł zawiera kod do tworzenia obiektów Perla reprezentujących
37 dowolne obiekty Nagiosa. Wszystkie klasy Perla są generowane
38 automatycznie w czasie kompilacji, więc łatwo dodawać nowe atrybuty
39 czy nawet całe obiekty.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Build.PL \
46         installdirs=vendor \
47         destdir=$RPM_BUILD_ROOT
48 ./Build
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 mv $RPM_BUILD_ROOT{%{_bindir}/*,%{_examplesdir}/%{name}-%{version}}
58
59 rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
60 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/.packlist
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc ChangeLog README
68 %{perl_vendorlib}/Nagios
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 1.829345 seconds and 4 git commands to generate.