]> git.pld-linux.org Git - packages/perl-Nagios-Object.git/blob - perl-Nagios-Object.spec
- BR: perl-Module-Build
[packages/perl-Nagios-Object.git] / perl-Nagios-Object.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Nagios
7 %define         pnam    Object
8 Summary:        Nagios::Object - Perl objects to represent Nagios objects
9 Summary(pl.UTF-8):      Nagios::Object - obiekty Perla reprezentujące obiekty Nagiosa
10 Name:           perl-Nagios-Object
11 Version:        0.08
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TOBEYA/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  59cf6e6286abcd26674b4da092e4759b
17 URL:            http://search.cpan.org/dist/Nagios-Object/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module contains the code for creating Perl objects to represent
26 any of the Nagios objects. All of the Perl classes are auto-generated
27 at compile-time, so it's pretty trivial to add new attributes or even
28 entire objects.
29
30 %description -l pl.UTF-8
31 Ten moduł zawiera kod do tworzenia obiektów Perla reprezentujących
32 dowolne obiekty Nagiosa. Wszystkie klasy Perla są generowane
33 automatycznie w czasie kompilacji, więc łatwo dodawać nowe atrybuty
34 czy nawet całe obiekty.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         installdirs=vendor \
42         destdir=$RPM_BUILD_ROOT
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -a bin/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/.packlist
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc ChangeLog README
62 %{perl_vendorlib}/Nagios
63 %{_mandir}/man3/*
64 %{_examplesdir}/*
This page took 0.450667 seconds and 4 git commands to generate.