]> git.pld-linux.org Git - packages/perl-Mozilla-CA.git/blob - perl-Mozilla-CA.spec
use system ca-certificates
[packages/perl-Mozilla-CA.git] / perl-Mozilla-CA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Mozilla
6 %define         pnam    CA
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mozilla::CA - Mozilla's CA cert bundle in PEM format
9 Summary(pl.UTF-8):      Mozilla::CA - pakiet certyfikatów CA Mozilli w formacie PEM
10 Name:           perl-Mozilla-CA
11 Version:        20130114
12 Release:        1
13 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Mozilla/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  45a42082dbd68cf25869ceb2aa49d5b2
17 Patch0:         system-ca-certificates.patch
18 URL:            http://search.cpan.org/dist/Mozilla-CA/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       ca-certificates
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Mozilla::CA provides a path to ca-certificates copy of Mozilla's
27 bundle of certificate authority certificates in a form that can be
28 consumed by modules and libraries based on OpenSSL.
29
30 %description -l pl.UTF-8
31 Mozilla::CA dostarcza kopię pakietu certyfikatów CA (Certificate
32 Authority) w postaci nadającej się do odczytu przez moduły i
33 biblioteki oparte na OpenSSL.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p1
38
39 # Do not distribute Mozilla downloader, we take certificates from ca-certificates package
40 rm mk-ca-bundle.pl
41 sed -i '/^mk-ca-bundle.pl$/d' MANIFEST
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Mozilla/CA.pm
63 #%{perl_vendorlib}/Mozilla/CA
64 %{_mandir}/man3/Mozilla::CA.3pm*
This page took 0.092796 seconds and 4 git commands to generate.