]> git.pld-linux.org Git - packages/perl-Mozilla-CA.git/blob - perl-Mozilla-CA.spec
up to 20200520
[packages/perl-Mozilla-CA.git] / perl-Mozilla-CA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Mozilla
6 %define         pnam    CA
7 Summary:        Mozilla::CA - Mozilla's CA cert bundle in PEM format
8 Summary(pl.UTF-8):      Mozilla::CA - pakiet certyfikatów CA Mozilli w formacie PEM
9 Name:           perl-Mozilla-CA
10 # although upsream has new releases, there is no benefit of that other than
11 # feeling library is fresh, as we do not use certs provided by this module.
12 Version:        20200520
13 Release:        1
14 License:        MPL v2.0
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Mozilla/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8ac3fe1a83c45da3f468f78ab8133ea6
18 Patch0:         system-ca-certificates.patch
19 URL:            http://search.cpan.org/dist/Mozilla-CA/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       ca-certificates
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Mozilla::CA provides a path to ca-certificates copy of Mozilla's
28 bundle of certificate authority certificates in a form that can be
29 consumed by modules and libraries based on OpenSSL.
30
31 %description -l pl.UTF-8
32 Mozilla::CA dostarcza kopię pakietu certyfikatów CA (Certificate
33 Authority) w postaci nadającej się do odczytu przez moduły i
34 biblioteki oparte na OpenSSL.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39
40 # Do not distribute Mozilla downloader, we take certificates from ca-certificates package
41 %{__rm} mk-ca-bundle.pl
42 sed -i '/^mk-ca-bundle.pl$/d' MANIFEST
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Mozilla/CA.pm
64 %{_mandir}/man3/Mozilla::CA.3pm*
This page took 0.12338 seconds and 4 git commands to generate.