]> git.pld-linux.org Git - packages/perl-Mozilla-CA.git/blob - perl-Mozilla-CA.spec
up to 20160104, no code changes, no cert changes (using ca-certificates package)
[packages/perl-Mozilla-CA.git] / perl-Mozilla-CA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Mozilla
6 %define         pnam    CA
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mozilla::CA - Mozilla's CA cert bundle in PEM format
9 Summary(pl.UTF-8):      Mozilla::CA - pakiet certyfikatów CA Mozilli w formacie PEM
10 Name:           perl-Mozilla-CA
11 # although upsream has new releases, there is no benefit of that other than
12 # feeling library is fresh, as we do not use certs provided by this module.
13 Version:        20160104
14 Release:        1
15 License:        MPL v2.0
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Mozilla/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  1b91edb15953a8188f011ab5ff433300
19 Patch0:         system-ca-certificates.patch
20 URL:            http://search.cpan.org/dist/Mozilla-CA/
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       ca-certificates
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Mozilla::CA provides a path to ca-certificates copy of Mozilla's
29 bundle of certificate authority certificates in a form that can be
30 consumed by modules and libraries based on OpenSSL.
31
32 %description -l pl.UTF-8
33 Mozilla::CA dostarcza kopię pakietu certyfikatów CA (Certificate
34 Authority) w postaci nadającej się do odczytu przez moduły i
35 biblioteki oparte na OpenSSL.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 # Do not distribute Mozilla downloader, we take certificates from ca-certificates package
42 rm mk-ca-bundle.pl
43 sed -i '/^mk-ca-bundle.pl$/d' MANIFEST
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/Mozilla/CA.pm
65 #%{perl_vendorlib}/Mozilla/CA
66 %{_mandir}/man3/Mozilla::CA.3pm*
This page took 0.093716 seconds and 4 git commands to generate.