]> git.pld-linux.org Git - packages/perl-MooseX-Daemonize.git/blob - perl-MooseX-Daemonize.spec
- initial
[packages/perl-MooseX-Daemonize.git] / perl-MooseX-Daemonize.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    MooseX
7 %define pnam    Daemonize
8 Summary:        MooseX::Daemonize - Role for daemonizing your Moose based application
9 Summary(pl.UTF-8):      MooseX::Daemonize - narzędzie do tworzenia demonów z aplikacji opartych o Moose
10 Name:           perl-MooseX-Daemonize
11 Version:        0.08
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  24ff349f0e2e09ca89e8ecbc73b0dc65
18 URL:            http://search.cpan.org/dist/MooseX-Daemonize/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(MooseX::Getopt) >= 0.07
23 BuildRequires:  perl(MooseX::Types::Path::Class)
24 BuildRequires:  perl-Moose >= 0.33
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Often you want to write a persistant daemon that has a pid file, and
31 responds appropriately to Signals. This module provides a set of basic
32 roles as an infrastructure to do that.
33
34 %description -l pl.UTF-8
35 Często pojawia się potrzeba stworzenia trwałego demona, który posiada
36 plik pid i odpowiada właściwie na Sygnały. Moduł ten zapewnia zestaw
37 podstawowych mechanizmów by osiągnąć ten cel.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/MooseX/*.pm
62 %{perl_vendorlib}/MooseX/Daemonize
63 %{perl_vendorlib}/Test/MooseX/Daemonize.pm
64 %{_mandir}/man3/*
This page took 0.063273 seconds and 4 git commands to generate.