]> git.pld-linux.org Git - packages/perl-MooseX-Daemonize.git/blob - perl-MooseX-Daemonize.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MooseX-Daemonize.git] / perl-MooseX-Daemonize.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    MooseX
6 %define pnam    Daemonize
7 Summary:        MooseX::Daemonize - Role for daemonizing your Moose based application
8 Summary(pl.UTF-8):      MooseX::Daemonize - narzędzie do tworzenia demonów z aplikacji opartych o Moose
9 Name:           perl-MooseX-Daemonize
10 Version:        0.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fede7bd0885a41e2156afea00b19cf5a
17 URL:            http://search.cpan.org/dist/MooseX-Daemonize/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(MooseX::Getopt) >= 0.07
22 BuildRequires:  perl(MooseX::Types::Path::Class)
23 BuildRequires:  perl-Moose >= 0.33
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Often you want to write a persistant daemon that has a pid file, and
30 responds appropriately to Signals. This module provides a set of basic
31 roles as an infrastructure to do that.
32
33 %description -l pl.UTF-8
34 Często pojawia się potrzeba stworzenia trwałego demona, który posiada
35 plik pid i odpowiada właściwie na Sygnały. Moduł ten zapewnia zestaw
36 podstawowych mechanizmów by osiągnąć ten cel.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/MooseX/*.pm
61 %{perl_vendorlib}/MooseX/Daemonize
62 %dir %{perl_vendorlib}/Test/MooseX
63 %{perl_vendorlib}/Test/MooseX/Daemonize.pm
64 %{_mandir}/man3/*
This page took 0.061916 seconds and 4 git commands to generate.