]> git.pld-linux.org Git - packages/perl-Math-BigInt-GMP.git/blob - perl-Math-BigInt-GMP.spec
- fixed perl-devel BR
[packages/perl-Math-BigInt-GMP.git] / perl-Math-BigInt-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Math
7 %define pnam    BigInt-GMP
8 Summary:        Math::BigInt::GMP - use the GMP library for Math::BigInt routines
9 Summary(pl):    Math::BigInt::GMP - wykorzystanie biblioteki GMP do funkcji Math::BigInt
10 Name:           perl-Math-BigInt-GMP
11 Version:        1.14
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3067740831f9b47ed8ae852753c411c6
18 BuildRequires:  gmp-devel
19 BuildRequires:  perl-Math-BigInt >= 1.64
20 BuildRequires:  perl(Math::BigFloat) >= 1.38
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl-Math-BigInt >= 1.64
24 Requires:       perl(Math::BigFloat) >= 1.38
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Math::BigInt::GMP provides support for big integer calculations via
29 means of the GMP C-library. Math::BigInt::GMP now no longer uses
30 Math::GMP, but provides it's own XS layer to access the GMP C-library.
31 This cuts out another (perl sub routine) layer and also reduces the
32 memory footprint by not loading Math::GMP and Carp at all.
33
34 %description -l pl
35 Math::BigInt::GMP dostarcza obs³ugê obliczeñ na wielkich liczbach
36 ca³kowitych z wykorzystaniem funkcjonalno¶ci biblioteki C GMP. Modu³
37 ten ju¿ nie u¿ywa Math::GMP, ale dostarcza w³asn± warstwê XS do
38 odwo³ywania siê do biblioteki GMP w C. Dziêki temu nie ma kolejnej
39 warstwy (podprocedury Perla), a wykorzystanie pamiêci jest mniejsze
40 dziêki nie wczytywaniu modu³ów Math::GMP i Carp.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc BUGS CHANGES CREDITS LICENSE README TODO
65 %{perl_vendorarch}/Math/BigInt/GMP.pm
66 %dir %{perl_vendorarch}/auto/Math/BigInt/GMP
67 %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.bs
68 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.so
69 %{_mandir}/man3/*
This page took 0.108262 seconds and 4 git commands to generate.