]> git.pld-linux.org Git - packages/perl-Math-BigInt-GMP.git/blob - perl-Math-BigInt-GMP.spec
perl 5.38.0 rebuild
[packages/perl-Math-BigInt-GMP.git] / perl-Math-BigInt-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    BigInt-GMP
7 Summary:        Math::BigInt::GMP - use the GMP library for Math::BigInt routines
8 Summary(pl.UTF-8):      Math::BigInt::GMP - wykorzystanie biblioteki GMP do funkcji Math::BigInt
9 Name:           perl-Math-BigInt-GMP
10 Version:        1.6011
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d0eff364a67026ed8543e327879695e9
17 URL:            http://search.cpan.org/dist/Math-BigInt-GMP/
18 BuildRequires:  gmp-devel
19 BuildRequires:  perl-Math-BigInt >= 1.999812
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Test-Simple >= 0.94
24 %endif
25 Requires:       perl-Math-BigInt >= 1.999801
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Math::BigInt::GMP provides support for big integer calculations via
30 means of the GMP C-library. Math::BigInt::GMP now no longer uses
31 Math::GMP, but provides it's own XS layer to access the GMP C-library.
32 This cuts out another (perl sub routine) layer and also reduces the
33 memory footprint by not loading Math::GMP and Carp at all.
34
35 %description -l pl.UTF-8
36 Math::BigInt::GMP dostarcza obsługę obliczeń na wielkich liczbach
37 całkowitych z wykorzystaniem funkcjonalności biblioteki C GMP. Moduł
38 ten już nie używa Math::GMP, ale dostarcza własną warstwę XS do
39 odwoływania się do biblioteki GMP w C. Dzięki temu nie ma kolejnej
40 warstwy (podprocedury Perla), a wykorzystanie pamięci jest mniejsze
41 dzięki nie wczytywaniu modułów Math::GMP i Carp.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc BUGS CHANGES CREDITS LICENSE README TODO
67 %{perl_vendorarch}/Math/BigInt/GMP.pm
68 %dir %{perl_vendorarch}/auto/Math/BigInt/GMP
69 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.so
70 %{_mandir}/man3/Math::BigInt::GMP.3pm*
This page took 0.13106 seconds and 4 git commands to generate.