]> git.pld-linux.org Git - packages/perl-Log-Any.git/blob - perl-Log-Any.spec
- up to 0.14
[packages/perl-Log-Any.git] / perl-Log-Any.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Log
6 %define         pnam    Any
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Log::Any -- Bringing loggers and listeners together
9 #Summary(pl.UTF-8):     
10 Name:           perl-Log-Any
11 Version:        0.14
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Log/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7def42641574ab11589252a4f7ad2c00
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Log-Any/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Log::Any allows CPAN modules to safely and efficiently log messages, while
29 letting the application choose (or decline to choose) a logging mechanism such
30 as Log::Dispatch or Log::Log4perl.
31
32 Log::Any has a very tiny footprint and no dependencies beyond Perl 5.6,
33 which makes it appropriate for even small CPAN modules to use. It defaults to
34 'null' logging activity, so a module can safely log without worrying about
35 whether the application has chosen (or will ever choose) a logging mechanism.
36
37 The application, in turn, may choose one or more logging mechanisms via
38 Log::Any::Adapter.
39
40
41
42 # %description -l pl.UTF-8
43 # TODO
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes INSTALL README
67 %{perl_vendorlib}/Log/*.pm
68 %{perl_vendorlib}/Log/Any
69 %{_mandir}/man3/*
This page took 0.532877 seconds and 4 git commands to generate.