]> git.pld-linux.org Git - packages/perl-Log-Any.git/blob - perl-Log-Any.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Log-Any.git] / perl-Log-Any.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Log
6 %define         pnam    Any
7 Summary:        Log::Any -- Bringing loggers and listeners together
8 Name:           perl-Log-Any
9 Version:        1.707
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Log/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  610f81b7b74859a105790347472dce34
16 URL:            http://search.cpan.org/dist/Log-Any/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Log::Any allows CPAN modules to safely and efficiently log messages,
24 while letting the application choose (or decline to choose) a logging
25 mechanism such as Log::Dispatch or Log::Log4perl.
26
27 Log::Any has a very tiny footprint and no dependencies beyond Perl
28 5.6, which makes it appropriate for even small CPAN modules to use. It
29 defaults to 'null' logging activity, so a module can safely log
30 without worrying about whether the application has chosen (or will
31 ever choose) a logging mechanism.
32
33 The application, in turn, may choose one or more logging mechanisms
34 via Log::Any::Adapter.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Log/*.pm
59 %{perl_vendorlib}/Log/Any
60 %{_mandir}/man3/*
This page took 0.073966 seconds and 4 git commands to generate.